QuickFix : l’installation de GLPI se bloque à l’étape trois (IIS 10)

Petit quick-fix pour ceux qui, installant GLPI sur Windows Server avec le moteur IIS, se retrouve bloqué à l’étape 3.

L’origine du problème

Lorsque le script d’installation s’exécute, il doit copier un certain nombre de fichiers et exécuter des scripts : cela prend plus de temps que ne l’autorise le module FastCGI de IIS (time-out de 60s).

Solution

Vous devez allonger le time-out du module. Pour cela, exécutez les actions suivantes :

  • Ouvrez l’interpréteur de commande (cmd.exe)
  • Exécutez la commande :
%windir%\system32\inetsrv\appcmd set config -section:system.webServer/fastCgi /[fullPath='"C:\Program Files (x86)\Php\7.2.8\php-cgi.exe"'].activityTimeout:600

Relancez ensuite l’installation de zéro en supprimant le fichier config_db.php qui est présent dans le dossier config du site.

 

Lien Permanent pour cet article : https://ms-sec.fr/?p=2749

(1 commentaire)

    • francois on 8 janvier 2019 at 11 h 05 min
    • Répondre

    Bonjour,

    J’ai le problème a l’étape trois, j’ai appliqué le Quickfix, mais j’ai l’erreur suivante:

    PHP Notice: Undefined index: glpilanguage in C:\GLPI\9.3.3\inc\html.class.php on line 1168
    PHP Notice: Undefined index: in C:\GLPI\9.3.3\inc\html.class.php on line 1168

    Je pense que d’avoir arrêté le déroulement de l’étape 3 m’a générer cette erreur ?

Laisser un commentaire

Votre adresse ne sera pas publiée.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.